Check out our Services Statuspage here ➜
Catchpoint Systems Nodes
New Nodes Release Bucharest/Romania
Incident Report for Catchpoint Systems Node Page
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 10:31 EDT
Monitoring
Catchpoint have deployed new nodes to the following locations.

Bucharest, RO - RDS
Bucharest, RO - RDS IPv6
Posted Jun 21, 2022 - 13:11 EDT
This incident affected: Individual Node Maintenance.