Verification is currently underway for the maintenance items.
Posted May 20, 2026 - 08:49 EDT
Update
Europa Agent has been deployed to all the Lastmile & Wireless nodes.
Posted May 20, 2026 - 08:49 EDT
Update
Europa Agent has been deployed to all the CHINA Backbone & Cloud nodes.
Posted May 19, 2026 - 05:02 EDT
Update
Europa Agent has been deployed to all the APAC Backbone & Cloud nodes.
Posted May 14, 2026 - 19:43 EDT
Update
Europa Agent has been deployed to all the EMEA Backbone & Cloud nodes.
Posted May 12, 2026 - 12:04 EDT
Update
Europa Agent has been deployed to all the US-West Backbone & Cloud nodes.
Posted May 11, 2026 - 08:46 EDT
Update
Europa Agent has been deployed to all the US-East Backbone & Cloud nodes.
Posted May 07, 2026 - 10:16 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 07, 2026 - 01:29 EDT
Scheduled
Europa agent has been deployed to following nodes.
Backbone: Dallas, US - Cogent Dallas, US - Cogent IPv6 Philadelphia, US - Comcast Philadelphia, US - Comcast IPv6 Seattle, US - Comcast Seattle, US - Comcast IPv6