Check out our Services Statuspage here ➜
Catchpoint Systems Nodes
Backbone nodes Hangzhou, CN (China Telecom, China Unicom, China Mobile) unplanned maintenance
Incident Report for Catchpoint Systems Node Page
Resolved
This incident has been resolved.
Posted Jul 20, 2021 - 11:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2021 - 22:02 EDT
Update
Hangzhou, CN - China Unicom is back up now operational.

Hangzhou, CN - China Telecom, and Hangzhou, CN - China Mobile nodes are still under maintenance.
Posted Jul 16, 2021 - 19:42 EDT
Investigating
Catchpoint Backbone nodes below have been paused due to an unplanned maintenance at provider end and will not run tests. We will update the status as soon as there is additional information available.

Hangzhou, CN - China Telecom
Hangzhou, CN - China Mobile
Hangzhou, CN - China Unicom
Posted Jul 16, 2021 - 14:33 EDT
This incident affected: Individual Node Maintenance.