Check out our Services Statuspage here ➜
Catchpoint Systems Nodes

Node ISP Name Change from Level3 To Lumen

Incident Report for Catchpoint Systems Node Page

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 20:40 EDT

Monitoring

As part of our alignment with industry-standard nomenclature, we have updated the ISP name for our nodes from Level3 to Lumen to reflect the provider’s current branding.
Posted Jul 01, 2025 - 11:46 EDT
This incident affected: Individual Node Maintenance.